java:-source 1.6 中不支持 diamond 运算符

广告位

  问题: 报错显示:  -source 1.6 中不支持 diamond 运算符 解决: 我使用的…

 

问题:

报错显示:  -source 1.6 中不支持 diamond 运算符

java:-source 1.6 中不支持 diamond 运算符

解决:

  • 我使用的版本是 1.8的 , 使用低版本就会报错,不支持,把pom.xml文件中的配置改成8即可,按自己版本来

首先:

点下图可以配置成自己的版本:

java:-source 1.6 中不支持 diamond 运算符

java:-source 1.6 中不支持 diamond 运算符

然后去Pom.xml文件修改即可

java:-source 1.6 中不支持 diamond 运算符

当然,可能你会没有这段配置,那就加上再修改成自己版本即可:

<build>     <plugins>         <plugin>             <groupId>org.apache.maven.plugins</groupId>             <artifactId>maven-compiler-plugin</artifactId>             <configuration>                 <source>8</source>                 <target>8</target>             </configuration>         </plugin>     </plugins> </build>

看完恭喜你,又知道了一点点!!!

你知道的越多,不知道的越多! 

~感谢志同道合的你阅读,  你的支持是我学习的最大动力 ! 加油 ,陌生人一起努力,共勉!!

注: 如果本篇有需要改进的地方或错误,欢迎大神们指定一二~~

天使的淚滴

关于作者: 天使的淚滴

为您推荐